WordPress 5.0已经推送,你会升级更新吗?

转载  博客导航    2018-12-07 09:52:06 

昨天开始收到 WordPress 5.0 的升级推送通知,在本地测试了一下,发现这个 WordPress 5.0 最大的特点就是将文章编辑器默认为Gutenberg 编辑器。老实说,这个 Gutenberg 编辑器一般人还真不习惯,boke112 导航也使用不习惯了,Gutenberg 编辑器界面如下:

WordPress 5.0已经推送,你会升级更新吗? - 第1张 - 懿古今(www.yigujin.cn)

为了照顾我们这帮不习惯 Gutenberg 编辑器的站长,WordPress 官方特意推出了 Classic Editor 插件,该插件就可以让我们选择是使用旧版编辑器(据说旧版编辑器支持到 2021 年)还是 Gutenberg 编辑器,发布短短的 7 个小时就有 60 多万人安装并启用(PS:不想安装插件就想禁止 Gutenberg 编辑器的,请移步:如何完美禁止 WordPress5.0 使用 Gutenberg 块编辑器?)。

WordPress 5.0已经推送,你会升级更新吗? - 第2张 - 懿古今(www.yigujin.cn)

安装并启用 Classic Editor 插件后,默认是使用旧版编辑器,如果想要切换编辑器,只需要在后台的设置(Settings)>> 撰写 >> Default editor for all users >> 选择相应的编辑器即可(其中 Classic Editor 是旧版编辑器,Block Editor 是 Gutenberg 编辑器)。

WordPress 5.0已经推送,你会升级更新吗? - 第3张 - 懿古今(www.yigujin.cn)

如果不是管理员而是普通注册用户的话,只要这个站点安装有 Classic Editor 插件,那么只需要登录后台,在编辑个人资料页面中就可以选择是旧版编辑器还是 Gutenberg 编辑器。具体见下图:

WordPress 5.0已经推送,你会升级更新吗? - 第4张 - 懿古今(www.yigujin.cn)

安装了 Classic Editor 插件之后是挺方便切换编辑器的,但是在编辑每一篇文章的时候都会自动添加一个自定义栏目 classic-editor-remember。如果是旧版编辑器,它的值就是 classic-editor;如果是 Gutenberg 编辑器,它的值就是 block-editor(PS:不想安装插件就想禁止 Gutenberg 编辑器的,请移步:如何完美禁止 WordPress5.0 使用 Gutenberg 块编辑器?)。

WordPress 5.0已经推送,你会升级更新吗? - 第5张 - 懿古今(www.yigujin.cn)

Boke112 导航建议大家在还没有熟悉 Gutenberg 编辑器,在没有确认自己所使用的主题和插件是否兼容 Gutenberg 编辑器和 WordPress5.0 的情况下,boke112 导航建议大家暂缓升级。据说到 2019 年 1 月份 WordPress5.0 将会更加稳定,到时候再升级也不迟(PS:不想升级又不想看到升级提示,可参考『不想升级到 WordPress 5.0 如何禁止更新提醒?』)。如果你还是要升级,建议在升级之前做好以下工作:

  • 联系主题作者确认主题是否支持 WordPress5.0;
  • 关注所使用的插件是否支持 WordPress5.0;
  • 备份整个网站,如果有阿里云快照功能的,不妨也建立一个新的快照以备用;
  • 安装 Classic Editor 插件,以便在旧版编辑器和 Gutenberg 编辑器之间切换。

你可能感兴趣的文章

温馨提示:文章内容系作者个人观点,不代表懿古今对观点赞同或支持。
版权声明:本文为转载文章,来源于 博客导航 ,版权归原作者所有!转载此文是出于传递更多信息之目的,若有来源标注错误或侵犯了您的合法权益,请与老古(QQ:2226524923)联系,老古将及时更正、删除,谢谢!

发表评论

大笑表情偷笑表情鼓掌表情思考表情疑问表情抠鼻表情抓狂表情晕表情黑线表情流汗表情流泪表情囧表情衰表情围观表情OK表情牛表情

表情

  1. 大致
    大致 @回复

    不升。WP的传统是大版本必出大bug,怎么也得等5.0.1才行。

    • 懿古今
      懿古今2018-12-13 11:00  回复

      @大致这个大版本除了看到新编辑器之外,都看不到有什么了,所以如果可以都不想升级了

  2. 久伴博客
    久伴博客 @回复

    5.0除了新的编辑器还有什么特点更新没

  3. 林三
    林三 @回复

    我只说一句,我不喜欢那烦人的编辑器,我就喜欢原始的简单编辑器。

    • 懿古今
      懿古今2018-12-10 17:54  回复

      @林三现在是可以直接禁止块编辑器的,我也不喜欢,还是经典编辑器比较好

  4. 中意眼镜工作室
    中意眼镜工作室 @回复

    看它提示的烦,升级了,只不过编辑器是英文的,据知更鸟说中文遥遥无期,没办法,暂时又装了个插件

  5. 卡卡讯
    卡卡讯 @回复

    刚更新,看说明应该是编辑器更新了,由于我是使用的markdown编辑器,所以 没太注意哪里有变化。

  6. 青山
    青山 @回复

    坚决不更新~

  7. maqingxi
    maqingxi @回复

    编辑器为什么没有简体中文版的?用起来不顺手呀。

    • 懿古今
      懿古今2018-12-07 12:25  回复

      @maqingxi可能还没有更新吧,所以文中也建议大家有需要升级的可以考虑到1月份稳定后再说

  8. 我就爱旅游
    我就爱旅游 @回复

    很好用,非常不错,而且美观,只是刚开始不习惯,用几天就顺手了。

    • 懿古今
      懿古今2018-12-07 12:26  回复

      @我就爱旅游[强] 适应性真的很强,我的文章大多数都是文章和图片,感觉这个新编辑器太强大了反而不合适

  9. 紫晨
    紫晨 @回复

    我已经升了,更新了安全性高些。

    • 懿古今
      懿古今2018-12-07 12:27  回复

      @紫晨[强] 神速啊,大版本升级一般是功能性的,小版本升级是漏洞方面的,所以做好小版本的及时更新就行,大版本可以稍慢一些。